Поднимаем VRRP на двух Mikrotik’ах ++

Пришлось мне ставить на работе еще один Mikrotik, т.к. один с нагрузкой уже не справлялся. А почему бы и не сделать отказоустойчивую систему, в случа падения одного из них?

VRRP для этого отлично подходит. Итак, для начала, что такое VRRP?

VRRP (Virtual Router Redundancy Protocol) — сетевой протокол, предназначенный для увеличения доступности маршрутизаторов выполняющих роль шлюза по умолчанию. Это достигается путём объединения группы маршрутизаторов в один виртуальный маршрутизатор и назначения им общего IP-адреса, который и будет использоваться как шлюз по умолчанию для компьютеров в сети.

В принципе, по описанию все довольно просто. Итак, настраиваем первый Mikrotik — R1:

/ip address add address=192.168.1.1/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49 priority=254
/ip address add address=192.168.1.254/32 interface=vrrp1

На втором Mikrotik‘е — R2:

/ip address add address=192.168.1.2/24 interface=ether1
/interface vrrp add interface=ether1 vrid=49
/ip address add address=192.168.1.254/32 interface=vrrp1

Имейте ввиду, меньший priority имеет подчиненный роутер, т.е. резервный. По умолчанию priority равен 100.

Проверяем на R1:

/interface vrrp print
 0   RM name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:31 arp=enabled interface=ether1 vrid=49
        priority=254 interval=1 preemption-mode=yes authentication=none password="" on-backup=""
        on-master=""

Проверяем на R2:

/interface vrrp print
 0    B name="vrrp1" mtu=1500 mac-address=00:00:5E:00:01:31 arp=enabled interface=ether1 vrid=49
        priority=100 interval=1 preemption-mode=yes authentication=none password=""
        on-backup="" on-master="

Результат, MAC одинаков на обоих роутерах. Ну и окончательная проверка. Пингаем из сети адрес 192.168.1.254 и выдергиваем сетевой кабель из R1. Пинг будет продолжать идти.

Таким же образом можно дублировать и внешний канал, что у меня и сделано. Очень удобно получается.

И еще одна хитрость — VRRP не работает на VLAN‘ах. Но ведь VLAN завернуть в VRRP никто не мешает. 😉

Вы можете оставить комментарий, или поставить трэкбек со своего сайта.

11 комментариев(я)

(Обязательно)
(Обязательно, не публикуется)

Яндекс.Метрика beget