Communigate PRO как MTA или установка logwatch

Все никак не доходили руки до установки logwatch. Дело в том, что logwatch не устанавливается без MTA и подсовывает для установки Exim. Но у меня уже стоит Communigate и он не опознается как MTA.

Пришлось ковырять форумы и спрашивать народ на канале #ubuntu-ru. В общем лечится все это довольно просто. Устанавливаем equivs.

# apt-get install equivs

Далее нам надо создать .control файл для определения псевто-MTA и создания deb-пакета.

# equivs-control ~/Communigate.control

Содержимое файла делаем примерно такое:

### Commented entries have reasonable defaults.
### Uncomment to edit them.
Section: misc
Priority: optional
Standards-Version: 3.6.2

Package: mta-local
Provides: mail-transport-agent
# Version:
# Maintainer: Your Name
# Pre-Depends:
# Depends:
# Recommends:
# Suggests:
# Provides:
# Replaces:
# Architecture: all
# Copyright:
# Changelog:
# Readme:
# Extra-Files:
Description:
long description and info
.
second paragraph

# equivs-build ~/Communigate.control
# dpkg -i ~/mta-local_1.0_all.deb

Собственно теперь ставим сам logwatch и наслаждаемся ежедневными отчетами в почте. :)

# apt-get install logwatch

Отдельное спасибо за терпение и помощь omnil с канала #ubuntu-ru. Советую. Там прекрасные люди. :)

Вы можете оставить комментарий, или поставить трэкбек со своего сайта.

Нет комментариев

(Обязательно)
(Обязательно, не публикуется)

Hастоящий админ знает только об одном типе архивов - tgz.
Яндекс.Метрика beget